Unity C#のバージョンを上げるべし

Unityはデフォルトのc#のバージョンが4.0で自動プロパティなどが使えない。上げるには設定で6.0に上げる必要がある。

 

UnityのC#バージョンを6.0にして文字列埋め込みを使う - しめ鯖日記

 

それはそうと、c#8.0ではインターフェースにデフォルトメソッドが実装されると喜んでいたのだが、どうも.NETの修正が大変とかで、 .NET Framework 4.8 では提供されないとか。

これはc#の仕様には載るが、実装がまだってことでいいのかしらん?

 

C# 8.0 の予告 | ++C++; // 未確認飛行 C ブログ